WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 1
Registered: ‎11-16-2018

Wemo Mini 2A5 & FF1 Not Finding Home Network

I have scoured this community and other online resources to try to get these 2 Wemo outlets working. The app connects to the Wemo device, but thereafter the process fails at the same point every time - my home network never is discovered. The Wemo app either endlessly reports that it is "still working" at "discovering nearby networks," or the home network page appears with no networks listed. I never get past the point where the switch blinks white and amber.

 

I am using a Belkin N150/F9K1001V4 router.  My understanding of the specs is that the router operates only on the 2.4GHz band. The Wemo switches were tested in outlets that ranged from 10 to 30 inches away from the router. The Android devices using the app were less than 5 feet from the router.

 

I have tried the following steps to resolve this issue:

 

1. Changing the router channel from auto to 1, and also to 11.

2. Changing the router to 802.11g only.

3. Trying the Wemo app (v.1.21) on my Android smart phone and an Android tablet.

4. Resetting the Wemo switches (multiple times)

5. Plugging the Wemo switches into different outlets

6. Rebooting the router.

7. Treating the home network as hidden (even though it is broadcasting the SSID) and manually entering the SSID and alpha-numeric password.

8. Unchecking "remember network settings" in the app

 

I am posting here because many of the posts I've reviewed either are for Wemos that connected at one time, or the home network is identified but the connection with the Wemo device never occurs. I haven't seen many posts for the issue I am experiencing.

 

To the extent this may be a firmware issue (I just bought the devices a few days ago), the Wemo upgrade appears to be a catch-22 for someone in my situation. The Belkin instructions require that both the Wemo device and the device where the app is installed should be connected to the internet. Since I can't get the Wemo connected to my home network, and thereafter listed in the app, I can't see if a firmware upgrade is needed, let alone whether it would resolve my issue.

 

Anything else I should try before I pull the ripcord and move on to a more workable solution? Thank you for any assistance.

Moderator
Posts: 203
Registered: ‎08-22-2017

Re: Wemo Mini 2A5 & FF1 Not Finding Home Network

[ Edited ]

@RadioFlyer 

 

Let's have our Escalation Engineers look into this further and assist you better on the setback as you've already exhausted all troubleshooting steps required. Please shoot us an email at WemoCares@belkin.com along with the following details:

- Full Name.
- Phone Number.
- Location - City/State.
- Community Username.

- MAC Address of the Wemo Minis. 
- Link to this Community thread for reference.


We'll be looking forward to your email.

Carl_S 21985
WEMO Technical Support