WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 1
Registered: ‎08-31-2017

Wemo Mini Smart Plug - Unable to set up

I have tried and failed to set up 2 newly purchased Wemo mini smart plugs.

 

I have 2 plugs, showing the same symptoms. I connect to the plug local wifi, select my home wifi, enter the password. Then either of the following happens:

1 - app crashes and when I reopen the app it is stuck at "Opening Connection"

2 - app times out trying to connect to network

 

Things I've tried:

I have tried changing my wifi chanel

I have no special characters in my wifi SSID or password

I have reset both plugs at least 5 times each

I have attempted the setup while sitting 5' from my router

I have reset my router multiple times

I have tried setting up with both Android and IOS devices

 

I have an 2 year old Wemo switch (I think they call it the Insight now) that works perfectly. During setup of my new plugs I have unplugged that older switch since I read (in community forums) about possible interference.

 

I have just spent an hour on the phone with a level-1 support person (who was quite good) and we ran through a whole bunch of troubleshooting steps.

 

I'm now waiting for a callback from a level-2 support engineer.

 

Anyone have any ideas or suggestions? If I can't get this working, I'm inclined to return both units and find an alternative.

 

Thanks in advance!

Highlighted
Posts: 2
Registered: ‎09-12-2017

Re: Wemo Mini Smart Plug - Unable to set up

Just bought my first and last Wemo  wi-fi smart plug and having identical problem as you. The solution that is appearing more and more obvious to me, as I don't have hours to talk with techs who are only going to run me through all the things you and I have already tried, bring it back where I got it. Good luck.