WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Posts: 4
Registered: ‎04-06-2015
Accepted Solution

Wemo Switch not working after firmware update

I have the original Wemo switch, been working well for the past 18 months.. Today, a new update came up on my wemo app on my android phone, I accepted the update as usual.. After 10 minutes, appeared to have updated well, but now it would not turn on manually from the neither the app or physical switch. The app does animate the function of switching on or off, but the actual switch does not respond at all, and the rules are ignored as well. I did a reset, everything went well with setting it up with wifi, etc.. But same thing, will not physically turn on weather the button is pushed on the wemo, or via the app.

I checked the firmware version, its 8405
I came across another thread on here that specifically states "8405 is for the WEMO Insight only" how did my wemo switch end up with the wrong firmware if I don't even have the insight. Can someone please help? Is it possible to revert to the correct firmware version or downgrade??
Community Manager
Posts: 558
Registered: ‎05-27-2014

Re: Wemo Switch not working after firmware update

Can you send me a private message with the MAC address that the WEMO App has for your switch?  You can do the Tell us what you think > Report a problem report which will have all the info I need if that is easier for you.

 

I want to check the cloud and see if something weird was set up for your switch.

 

Regards,

Robert S.

Belkin Technical Support

Posts: 4
Registered: ‎04-06-2015

Re: Wemo Switch not working after firmware update

Hi Robert,
Thanks for your reply.. I sent you a private message with the Mac address, did you get it?
Posts: 4
Registered: ‎04-06-2015

Re: Wemo Switch not working after firmware update

Hi Robert,
Ignore my last reply.. I received your private message. Thanks
Community Manager
Posts: 558
Registered: ‎05-27-2014

Re: Wemo Switch not working after firmware update

For future reference on this thread...

 

For some reason the WEMO updated to the incorect firmware.  The report from the device of what version it has is WeMo_WW_2.00.8405.PVT-OWRT-Insight, 100, WeMo Switch.  The switch should have -SNS instead of -Insight firmware.  The description of what the device is doing definitely follows the symptoms of it installing the wrong firmware.  

 

I've never seen this happen in the field.  I have seen it here in our lab when I manually put the wrong firmware on a test device I had.  I put the SNS firmware on an Insight and the insight behaved the same way.  Unfortunately it looks like it can't be updated over the air and requires a replacement.

 

Regards,

Robert S.

Belkin Technical Support

Posts: 4
Registered: ‎04-09-2015

Re: Wemo Switch not working after firmware update

Mine is screwed too.  I have the plug in switch. it has worked fine til this firmware update last night. now it's worthless and won't connect.  HELP.  i sent a trouble log report thru my phone.

Posts: 1
Registered: ‎04-28-2015

Re: Wemo Switch not working after firmware update

I have the same issue. Original Wemo switch, applied today's firmware update and now can't communicate with any of  my switches. They are all bricked.

 

How do we fix this?

Posts: 248
Registered: ‎05-24-2014

Re: Wemo Switch not working after firmware update

Looks like you need to reset all your WEMO Switches. Manually Reset the WEMO devices for at least 5 seconds then reconfigure and reconnect them to the 2.4 GHz band of your network (if you're using a dual band router). 

 

 

Posts: 5
Registered: ‎04-29-2015

Re: Wemo Switch not working after firmware update

A reset doesn't fix it. All 3 of my original wemo switches upgraded and now I can only control them if connected to 4G. If I'm on wifi I don't see the switches. My wemo light switches and insight switches work fine. I guess I'll have to RMA all 3 switches.
Posts: 5
Registered: ‎04-29-2015

Re: Wemo Switch not working after firmware update

Note my firmware is WeMo_WW_2.00.8643.PVT-OWRT-SNS for all of my original wemo switches according to the Wemo app when connected to 4G.