WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 4
Registered: ‎09-19-2016

Wemo light switch won't respond to Alexa commands 100% of the time

[ Edited ]

Hello Wemo,

I have purchased 4 light switches from you over the past year, and I have a lot of complaints about the product.

 

This weekend I just purchasedthe TP-Link light switch. I must say, it's a far superior product at only $24.99 (on Amazon on the day of writing this). I paid  betweem $39.99 - $48.99 on Amazon for each of the Wemo switches.

 

 

Problem 1: It does not respond to alexa 100% of the time. At least 15% of the time i ask alexa to turn on/off lights it will say "Your device is not responding". The other 85% of the time when it does work, about 50% of that time, my Alexa lights will spin for a good 3-4 seonds before the switches respond. 

 

Actually, this is not just a problem with the light switches. I have 2 wall switches, and they experience the same problem.

 

I guess, this is the price I pay for purchasing a Gen 1 product

 

The TP-Link switch i had this weekend works perfectly with alexa. Instant response, on or off.  It's using the same wifi set-up i have, same router, same installation location.

 

Problem 2: The wemo app is terrible. SLow to start up (extremely slow to setting up devices), unresponsive at times, crashes frequently. ALso, once in a while, my devices are not detected until i navigate back and forth insidethe app a bit.

 

 

I am really disappointed that i spent over $150 throughout this last year on Wemo light switches and wall switches that work only most of the time Smiley Sad If there is a fix to the problem, please let me know. Otherwise, i will be giving away these light switches and replace them all with TP-Links.

 

 

Moderator
Posts: 519
Registered: ‎06-17-2015

Re: Wemo light switch won't respond to Alexa commands 100% of the time

Hi, @xinger. We understand your frustration. Don't worry, let's try to figure this out.


First thing that you can do is to reset and configure the Wemo devices again, then remove them from the Amazon Echo App. Make sure that the Echo does not have them on their list of home automation devices anymore.


After that, have Alexa re-detect the devices again to check if it will recognize them.


Update us if this works.

Thaddeus - 14850
WEMO Technical Support
Posts: 4
Registered: ‎09-19-2016

Re: Wemo light switch won't respond to Alexa commands 100% of the time

[ Edited ]

Hello Thaddeus,

Thanks for the response. I have already tried that several times.

 

All my light switches and wall plugs have frequent delays (spinning lights on Echo for a few seconds) when communicating with Alexa when it does work. And there are times when Alexa cannot detect the devices at all. When that happens, I have to try talking to Alexa (ie "Alexa, Turn on living room lights")  at least 1 or 2 more times before it detects them again.

 

Thanks

Moderator
Posts: 519
Registered: ‎06-17-2015

Re: Wemo light switch won't respond to Alexa commands 100% of the time

@xinger
Understood. Did you update anything on the Wemo device or App before this started happening? Was there also an update on the Amazon Echo?

Thaddeus - 14850
WEMO Technical Support
Posts: 4
Registered: ‎09-19-2016

Re: Wemo light switch won't respond to Alexa commands 100% of the time

Nothing changed on the Wemo App. I just uninstalled and reinstalled the app. 

Checked my Amazon Echo app and made sure it's the latest.

 

Also, like I said, i dont have any of such problems with the other connected smart products I have. Like the TP-link switch or Nest thermostat i have. They all respond to Alexa commands instantly and reliabily 100% of the time. 

 

It's ONLY the wemo products that give be problems since the day they were purchhased

Moderator
Posts: 519
Registered: ‎06-17-2015

Re: Wemo light switch won't respond to Alexa commands 100% of the time

@xinger
Understood. We'll have one of our technicians check your devices. Please send us your contact details at WemoCares@belkin.com. Also, include the link to this forum as a reference.

Thaddeus - 14850
WEMO Technical Support
Posts: 4
Registered: ‎09-19-2016

Re: Wemo light switch won't respond to Alexa commands 100% of the time

Awesome. Thank you.
Posts: 1
Registered: ‎02-01-2017

Re: Wemo light switch won't respond to Alexa commands 100% of the time

I have two WeMo Swithes (WeMo1 and WeMo 2). WeMo 2 responds to Alexa without any issue but WeMo 1 stopped responding to Alexa for no apparent reason a few days ago. Both devices can be accessed and turned on/off via the WeMo app without any issues. Please advise how to fix the WeMo 1 issue to allow it to work with Alexa again. Thanks.
Posts: 1
Registered: ‎02-07-2017

Re: Wemo light switch won't respond to Alexa commands 100% of the time

I'm having the same issues with Alexa and my 2 WeMo switches. Sometimes they are there and sometimes they're not. The App always seemed to find them and work. My Lutron devices ALWAYS WORK.
Posts: 1
Registered: ‎02-08-2017

Re: Wemo light switch won't respond to Alexa commands 100% of the time

exact same problem, i have a group in which only one device is present thats wemo device called "devices" group named party.. when i say Alexa, turn party on or off, it use to 100% work now it say device not responding, however when i say turn devices on it works, some thing to do with the update, please help with a solution on the forum so others can benifit from it! 

 

Original poster please update your situation!

 

Thanks