WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 11
Registered: ‎09-24-2017

Wemo link repeatedly fails

My Wemo link keeps flashing yellow (orange?). (4 times in 3 days). the only answer I get from level One support is "disconnect the WeMo link and reboot your router. "
while this seems to work briefly I'm getting tired of having to reboot my router constantly. It's clearly a problem with the WeMo link but level One support will not acknowledge that. I'm getting sick and tired of this and I'm ready to dump WeMo completely unless I find a solution or get the WeMo link replaced.
Highlighted
Moderator
Posts: 146
Registered: ‎08-22-2017

Re: Wemo link repeatedly fails


@Msantarc wrote:
My Wemo link keeps flashing yellow (orange?). (4 times in 3 days). the only answer I get from level One support is "disconnect the WeMo link and reboot your router. "
while this seems to work briefly I'm getting tired of having to reboot my router constantly. It's clearly a problem with the WeMo link but level One support will not acknowledge that. I'm getting sick and tired of this and I'm ready to dump WeMo completely unless I find a solution or get the WeMo link replaced.

We understand your sentiments towards this matter, Msantarc. Do you mean to say that the Wemo link is not connecting to the network? Can you connect to the setup SSID? For further isolation, let's try to plug the Wemo device near the router and check if that'll make any changes. If not, we can have this case endorsed to our escalation engineers. Just send us your contact details at Wemocares@belkin.com. 

  • Name/Username
  • Email address
  • Contact number
  • Link on this thread
  • Wemo devices in total
  • Wemo devices that are not working properly

Thank you.

Nestor - 21974
WEMO Technical Support