WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Posts: 1
Registered: ‎12-27-2017

Re: Wemo mini plug not connecting to wifi during setup

Perhaps this will help. Had the same issues described by others. All the suggested solutions that I tried failed for me. As a final act of desperation, I changed my router to use G-mode only. The mini-plug connected without further setup; it simply connected on its own. The WeMo app recognized the device was now on the network.


It's possible that this is an artifact of my router. I have a dual band router that I had rooted with dd-wrt. Other devices had no problem with the mixed G and N environment on 2.4 GHz that I used previously. That included over a dozen devices such a cell phones, notebook computers, Nook readers, Google tablets, Roku, Vizio TV, etc. But the WeMo mini was not happy with the mixed G/N setting. And I was able to replicate the behavior multiple times. Nonetheless, this change will work for me since I run the 5 Ghz band in N-mode only; using the 2.4 Ghz band as G-only is OK.


Hope this helps someone else.

Posts: 2
Registered: ‎12-30-2017

Re: Wemo mini plug not connecting to wifi during setup

Posts: 2
Registered: ‎12-30-2017

Re: Wemo mini plug not connecting to wifi during setup

I purchased one of these today. I had researched and wanted to buy a tp link smart plug but our local Best Buy was out of stock and this was supposedly the next best option. A quick search of amazon reviews while I was in the store still Had the Weko mini plug at 4 stars, almost as high as the tp link. I thought I’d go ahead and give it a try.

Here I am, typing this message nearly 5 hours later and I have not even been able to get this plug to find my WiFi network! The plug is 6 feet away from my router. I’ve read this thread and restarted my router, reinstalled the app numerous times, changed channels, made sure my phone was in the 2.4 ghz channel, changed to 802G, closed all other apps, tried to connect in airplane mode, etc. Not one suggestion on here as resulted in success.

I’ve only kept trying for so long because I CAN’T BELEIVe That this plug will not connect to my router! This is beyond ridiculous. This should be a 5 minutes process.

Pretty disappointed in this and will be going back to return this item ASAP. I mean really, I simply just can’t believe a company would sell a product like this that doesn’t just WORK.
Posts: 1,028
Registered: ‎12-08-2014

Re: Wemo mini plug not connecting to wifi during setup

[ Edited ]

Is your 2.4Ghz on 20Mhz channel width?  Not 20/40 or 40..but just 20...



If that doesn't work do you have an quick "open" test guest network to see if switch is outright defective. 

Posts: 1
Registered: ‎01-06-2018

Re: Wemo mini plug not connecting to wifi during setup


TLDR: if you previously set up the WeMo plug and it's not connecting, follow the steps below. The goal is to eliminate factors that makes the plug difficult to coonect.


  1. Remove the app and reinstall the app.
  2. To reset the plug, unplug the WeMo mini plug, plug it in and while it's booting up, flashing, press and hold the button until it flashes amber (orange).
  3. Reboot the router: if your router has a reboot button, use that. If not, reboot the router by unplug the power, wait for 10 minutes to plug it back in.
  4. The WeMo plug can only connects to your 2.4GHz network if you have both 2.4 & 5. I would recommend to give each frequency its own SSID to make it clear which band you are connecting to.
  5. Make sure your router allows other device to connect to it. If there is MAC filter, you got to have the WeMo's MAC in there and apply the changes.
  6. Turn off dual bandwidth. Only 20MHz. You can turn it back on later.
  7. Select specific channel. 1 or 11 is preferred.
  8. When setting up the plug, having it be next to the router to get strong signal and eliminate signal issue.
  9. When setting up the plug, don't change the default name, don't take a picture, don't make any other changes. You can always go back to make changes after it connects properly.

I had no problem with my WeMo mini plug when I first setup. Although the app was slow, very slow, but it works fine.


I had all my 3 WeMo plugs flashing amber light the other day. Unplug and plug it back in didn't work. Found this thread to reset my plugs. During set up, the app was not able to connect the plug to my router.. I checked everything in my router and it's all good. Reboot the router to eliminate a possible cause and the plug still won't connect to my router even though the SSID and password were typed correctly many times and tripple checked.


While checking settings on my router, I saw that I have dual bandwidth turned on. So I turned that off and make sure the channel is still 11. Plus, I set it to support 802.11 N only. This limited the scope it can go wrong while setting up the WeMo to connect to the router.


After all that elimination, finally, all my plugs connect to the router properly. I went back to the router admin page to change things back to dual bandwidth. The plug has been working properly ever since.

Posts: 1
Registered: ‎01-12-2018

Re: Wemo mini plug not connecting to wifi during setup

After reading your post, I thought about playing with the Mode on my 2.4GHz wireless network. My Mode was set to: "Up to 600 Mbps" and I reduced it to "Up to 54Mbps" and that did the trick for me. That wireless mode is the Legacy Mode, with a maximum speed of up to 54 Mbps for b/g networks.