WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 54
Registered: ‎02-01-2018

Re: Wemo mini plug not connecting to wifi during setup

Probably one of my favorite responses and what I have said as a software and application senior principal business systems analyst myself. LOL. It’s also why I have gone from 9 Wemo Minis to 3 and removed 1 Wemo wall switch and looking for a solution to remove 2 more wall switches as soon as I can find an alternative to my fluorescent lights. I’m not quite ready to invest $100’s in the competitors yet.
WEMO Maker Inventor
Posts: 1,776
Registered: ‎06-14-2014

Re: Wemo mini plug not connecting to wifi during setup

They are very good questions whether they were meant tongue in cheek or not Smiley Happy.

 

The setup problems are made much worse by the nonsense that support advises like the horrific practice of a complete reset and starting over after every glitch.

 

Unfortunately many of the easier and cheaper alternatives are huge security risks that can compromise your home network.  It might be a bit early to adopt IoT unless you know what you're doing, and at the very least stick with name brands owned by companies with strong security and privacy policies and laws.

 

The wemo hardware itself is pretty good, it's the app that struggles.  For a few hundred grand I or someone like me would be happy to re-write the setup section so it's at least moderately useable... Smiley Happy.

 

Until then a few tips might make it easier:

Set your router wifi security to WPA2, and if you don't know what that is, find out - whether or not you use wemo.

1) Try to set up the wemo near your router, if it's a plug you can move it later.  Power it up and wait a minute.

 2) If the wemo LED is not flashing alternate colors reset it and start again.

3) Look for and connect to the wemo's internal wifi signal from your handheld.  It can take a few minutes to show.  You may need to temporarily prevent your handheld from prefering connections with an internet connection (how is device specific).

4) If the wemo can't see your home wifi signal and show it in the app setup you're probably SOL.  If you're not at least a little technical pack it up and return it.

5) After providing your wifi password ignore what the app says about success or failure.  Watch the wemo's LED for a minute or too.  If it keeps flashing amber your password might be incorrect, try again.  Give up after a few tries - it's not going to work, time to return it.  If the LED is solid on or off you're good to go.  If the app can find the wemo this is a good time to update the firmware (if you can convince the app to prompt you for it!).

6) Move the wemo in it's final location, or power cycle (unplug and plug it back in) it, or restart if it's a switch.  If the wemo keeps flashing amber for longer than 5 minutes you probably can't use the wemo there. 

7) Power cycle your router and again watch your wemo LEDs.  If the wemos don't stop flashing another power cycle/restart of the wemo might work.  If not, reconfiguring your network might sort it but again, unless you're a little technical, better to pack it up.

 

Finding and controlling it from the app is a whole 'nuther story...  One option is to use an aftermarket app.

 

Mike
Reliable and secure (Belkin cloud-free) home automation and remote access:
AutomationManager/HomeBridge/WemoLEDs/WemoHome/MoreInfo
Posts: 7
Registered: ‎12-29-2015

Re: Wemo mini plug not connecting to wifi during setup

@Jan_B thanks for replying, I appreciate it. Since posting, and just before I packed these up to try and return them, they somehow "magically" started working again. Well, that's the entirely true; here's what I did...

 

Decided to try "one more thing":

  • Reset the mini again (hard reset)
  • Enabled a guest network (with a SSID in all lowercase and much shorter password)
  • Went through the mini config again connecting to my guest network
  • Now that it was finally showing on my network, I left it alone for a day
  • Because I don't want a guest network, using the app I reset the mini and hard reset it (because, why not?)
  • This time, connecting to my normal network worked
  • I did the same steps above for the 2nd mini that I was having problems with, the 3rd one I had yet to alter

What was interesting about the above is that after resetting 2 of the 3, the 3rd one decided to work again. Nothing had changed on my router except enabling the guest network (and yes, I had power-cycled the router a few times before and had been testing various changes as noted within these forums); this 3rd mini simply wouldn't connect to the network until after the above. Now it's behaving again.

 

Now all 3 of the mini's are working again on my 'normal' network and it is mystifiying as to why. There is no clear (AFAIK) reason for it. I went from 3 mini plugs working for ~ 3 months, to none of them working for no apparent reason, to working again after resetting (multiple times) 2 of the 3. Also keep in mind that I have other, older, Wemo devices which continued to work fine through all of the above -- this problem was isolated to the mini's. And no, during all of this I was never prompted to do a firmware update so can only assume that either a) they are already on the current version or b) an update hasn't been pushed to them yet from Belkin.

 

I was genearlly happy with Wemo before I bought the mini's. The mini's have been the most finiky product of them all (and I thought the link was troublesome). Setup is atrocious for these devices and even the thought of having to dumb-down my network just to get these to work is a big dissastifier (don't get me wrong, I sincerely appreciate the triage community members have done to try to find stability with these products), With that said, the one change that I had made months ago during the initial mini setup trouble that seemed to work was to change the 2.4 bandwith to 20Mhz. That no longer made any difference when these things just stopped working (because the setting didn't change and was changed back to 20/40Mhz during troubleshooting above).

 

Moderator
Posts: 159
Registered: ‎12-12-2017

Re: Wemo mini plug not connecting to wifi during setup


@GrandHolly wrote:

Same problem as everybody else. Received WeMo Mini as Christmas gift. Nice idea. Simple looking instructions.

 

Set up does not work.

 

My home Wifi doesn't display. Typing it in does not help.

 

I am having a hard time trying the fixes in this forum. I looked up G-board and default ios keyboard. Pretty sure I am not using a Google keyboard.

What is an SSID?

I have two wifis, one is 5 GHz & the other I don't know. How do you know what GHz your wifi is? Why do you sell a device that won't work on some wifis?

What is a router channel? How would one set its bandwidth?

What is a DHCP and how would one narrow it?

What is WeMo firmware?

What is power-cycling?

 

The WeMo is maybe 6' from the router.

 

The WeMo thing says 1.22.1; I presume that is its version.

iPhone 7.

Router Linksys EA7300.

 

I am a fully competent chemical engineer. I am not a router wizard. I cannot "try the suggested workarounds" since I don't know what you are talking about. My vocabulary is devolving into vulgarities. Is it possible for you to make your fix suggestions as simple as the original very-simple-but-totally-useless setup instructions?

 



Hello GrandHolly. If I may ask, what is the LED status of your Wemo device as of the moment? Have you tried changing its location nearer your router? If you haven't, please try that.

 

Answers to your question:

 - SSID - simply the technical term for a network name.

 - Network Bands - 5 GHz and 2.4 GHz (please know that Wemo only works with 2.4 GHz band)

 - What is a router channel? - WiFi or Router channel is the medium through which our wireless networks can send and receive data.

 - How would one set its bandwidth? - refers to the maximum amount of data that can be transmitted via an internet provider over a certain period of time.

 - What is a DHCP and how would one narrow it? - DHCP is what your router's main function, it translates one IP address into many so that more devices can connect to your network.

 - What is power-cycling? - This is just turning on/off your router.

 

 

Mark-22022
Wemo Technical Support
Posts: 7
Registered: ‎12-29-2015

Re: Wemo mini plug not connecting to wifi during setup

And... Mini plug #3 decided to stop connecting to my network. Using the info I shared above and other tips sprinkled throughout this thread, it will not connect to my normal network again, period. It has zero problem connecting to my guest network (the differences being an all lowercase SSID and shorter password for the guest network). The setup must be experiencing some problem with the password length. The error keeps saying to "...check the password..." and I am 100% positive it is correct.

 

Looks like I have 3 options:

1. Try changing the password on my preferred SSID to something shorter. That stinks b/c I'd need to change every other device that connects to it.

2. Move all Wemo to my guest network. The downside here is "what if" some have a problem connecting to that and I can't get them connected back to my preferred network? Then I'm really out of luck.

3. Give-up on the mini that doesn't want to connect again. With this option, I'm out $$ b/c I doubt I can return it (been too long since I bought it and no receipt anyhow). And if I'm going to return one of these troublesome devices, I want to return all of them.

 

 

 

 

 

Moderator
Posts: 223
Registered: ‎08-22-2017

Re: Wemo mini plug not connecting to wifi during setup

We understand your sentiments about this matter, tagalong. Please know that we support whatever decision you'll make. If you encounter further challenges again such as the Wemo device will not connect to the network, you may refer on our previous reply and we encourage you to send us an email so we can have this case escalated. Thank you.

Nestor - 21974
WEMO Technical Support