WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Posts: 2
Registered: ‎12-17-2017

Re: Wemo mini plug not connecting to wifi during setup

I'm having the same issue with a brand new Wemo Mini plug from BBY.  I've tried clearing app data/cache, uninstalling/reinstalling the app, changing router settings (modes, channels, etc.), factory resets of the Wemo, different device keyboards, moving the plug closer to the router, disabling cellular data, airplane mode, forgetting other wifi networks, turning off auto reconnect, extra characters in the wifi password, etc.  I've literally tried every suggestion on this forum and other sites on multiple devices ranging from a Samsung Galaxy S8+ to an iPad Mini (wifi only). Nothing works.


Even stranger is the fact that after a factory reset, although I have to start over with the setup process, the custom name of the Wemo Mini plug is still there despite all other settings being wiped out and starting the setup process from step 1. This is even after a fresh app installation and device factory reset. 


This product is utter garbage. I have an older Wemo Plug and a Wemo Switch (that have both had their fair share of problems, by the way). I just bought two of these minis: one for us and one for my parents as a Christmas gift and was planning on buying more if I liked the new style. It looks like I'll be returning both and trying one of the other options out there. The fact that I've spent hours tonight trying everything short of a magical connection dance is just a joke and shows that this product isn't worth a fraction of its price. Mind you, I'm not an inexperienced noob at home automation and networking. If a computer engineer with multiple Nest, Google Home, and other smart home products can't get this to work, then how in the world do you expect an average consumer to use these? I wouldn't dare give this to my parents along with a brand new Google Home to introduce them to smart home technology after tonight.


Sorry Belkin/Wemo, but you're high if you think this is acceptable. I'd trust a cheap knock off before this product. 

Posts: 1
Registered: ‎12-18-2017

Re: Wemo mini plug not connecting to wifi during setup

I am having the same problem.

I have flashing amber & white.

I see the Wemo mini and the signal is strong.

When I try to connect it says Internet may not be available.

All internet and router in home are working. Evrything else I own is working.

I have reset. I ahve tried disabling auto reconnect as some stated.

I cannot get this to work


Posts: 2
Registered: ‎12-17-2017

Re: Wemo mini plug not connecting to wifi during setup

Well I finally isolated the issue. Make sure you don't have any special characters in your SSID.  Even a simple underscore isn't supported by the Wemo Mini.

Posts: 4
Registered: ‎11-25-2017

Re: Wemo mini plug not connecting to wifi during setup

Anyone from Belkin Support going to read and respond to these WEMO Mini issues?

Posts: 2
Registered: ‎12-18-2017

Re: Wemo mini plug not connecting to wifi during setup

I bought 2 wemo minis tonight. I can't get anything to work I can connect to the wemo to change the name then when i hit next wemo never connects again and is never found on the network. Oh and the signal is garbage on this device. Funny how it's literally cheaper and easier to set up a hacked wemo code on arduino and attach a relay than it is to set up the offical product. As far as im concerned they belong in the garbage but ill return them as i dont want to waste money. These devices should connect and work out of the box. I shouldn't have to play around with wifi settings and reinstall apps.

Posts: 1
Registered: ‎12-22-2017

Re: Wemo mini plug not connecting to wifi during setup

Thank you! The only thing that made it work for me after many failed setup attempts was forgetting my home networks - what a pain but less of a pain than returning this lame wall plug. Please make the setup easier!!
Posts: 2
Registered: ‎12-23-2017

Re: Wemo mini plug not connecting to wifi during setup

I purchased 3 wemos - they all set up perfectly.

Then one stopped being recognized in the app.

Took it back and purchased 8 more.

None of the others worked - took all eight back and exchanged them for 8 more.


I have spend about 15 hours getting these set up and still no luck. I've tried all of the steps that everyone here has advised.


My conclusions:  I once thought highly of Belkin, but I will never purchase a product from them again. I can't tell if it is their lousy firmware or lousy app - or quite possibly both.  It is so disappointing to purchase from what used to be a reliable company and find such awful products.


My Solution: RETURN YOUR WEMO  and buy a TP-LINK.  I bought 1 TP Link light switch - install (and I'm not an electrician) took about 20 minutes - set up took 10 minutes - has never lost connection.  Hooked up with Alexa without a hitch - scheduling is not a problem at all!


Can anyone recommend any other brands?


Dear Belkin - get it together! 


You can expect a few more returns from me!

Posts: 102
Registered: ‎08-09-2017

Re: Wemo mini plug not connecting to wifi during setup

Hi everyone. Let's get this case over to our 2nd Level Support Team for further diagnosis and solution. Email us the following info at WemoCares@belkin.com


Full Name:
Phone Number:
Community Username:
Link to this thread:

Pamela - 21733
WEMO Technical Support
Posts: 1
Registered: ‎12-26-2017

Re: Wemo mini plug not connecting to wifi during setup

[ Edited ]

Pamela, with all due respect, this has been an issue, judging from posts I've seen online, since _2005__2015_.

Somehow suggesting people email you guys about this seems ludicrous. The info is here--and everywhere--if you guys--it's your product you're trying to sell, after all--actually care to solve it.

Don't make us care more about your products than you.

FYI I spent the last two days with two of these mini plugs with the same problems, disappointing my family--which was quite excited and then totally disappointed--and will be returning them. A shame, really, how long this product has stunk and yet received so very little actually-helpful support.

Posts: 2
Registered: ‎12-23-2017

Re: Wemo mini plug not connecting to wifi during setup

Thank you Mike!


This was most helpful, but had to try a few other things.  After about 20 hours of headache and deciding to return them. I slept on it and decided to give it one more shot.


Here is what worked for me:


1. Set 2.4Ghz  router to channel 6 - Channel 11 did not work for me (and yes I tried it). I have a linksys and I had to make

    sure I wasn't limiting it to too few devices.

2. For my android I click the bottom left button to display all the running apps.  Click on close all apps.

3. Go to the wifi settings and select the 2.4Ghz wifi.

4. Plug the WEMO in an outlet near where you get a strong connection (download a wifi analyzer app to verify your 

   connection - or make sure you have all bars on your phone)

5. Open the WEMO app.

6. Hold the button on the WEMO until it turns orange (mine did not flash orange/white - it just flashes white after that).

7. Go to the wifi settings and click on your wemo wifi - if it doesn't show up then try holding down the on off switch longer.


9. Go back to the WEMO app - I didn't personalize - just turn "remember my wifi settings" off (no green bar means off).

10. Click Next

11. It may take a minute or 2 to find your local networks. Be patient - It switches screen to display local networks and then it

     took a few minutes to find my 2.4Ghz network. (and I mean minutes - not seconds).

12. Click on your network and type in your password. Then it tries to find your network - mine always found "CELLULAR"


13. The light will turned solid white on my WEMO and then my phone connected to my local network and a list of my WEMO

      devices displayed.

14. I hit the off button on my WEMO - then unplugged it and moved it to the desired location.

15. Plug it back in and give it a minute - mine when orange at first - but after about 2 minutes I checked the app and it was up.

16. Make sure your are on the same wifi that you set your WEMO up on.

17. Lastly, I went back into the WEMO app and clicked the edit to change the name and the picture.


I have 9 of them up and happy.  Thanks all for your help.


All that being said.  Belkin - update your app - update your instructions!  I gave a few of these as a gift and I am quite worried that someone who is not tech savvy won't figure all of this out!


For a smart device it is quite dumb!


Also, my 2 cents - I prefer the TP-Link app - you may want to check it out - so many more options for scheduling!