WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Reply
Posts: 2
Registered: ‎12-10-2016

Re: Wemo won't Connect to Wifi after power outtage

Finally got sick of having to factory reset my 4 switches every time I lose power (which happens at least once a week in my condo)

 

Gonna hock them on ebay and get a competitor's switches...

Posts: 1,064
Registered: ‎12-08-2014

Re: Wemo won't Connect to Wifi after power outtage


@p1r473 wrote:

Finally got sick of having to factory reset my 4 switches every time I lose power (which happens at least once a week in my condo)

 

Gonna hock them on ebay and get a competitor's switches...


What models?  I am definitely interested.

WEMO Maker Inventor
Posts: 1,773
Registered: ‎06-14-2014

Re: Wemo won't Connect to Wifi after power outtage

Post the ebay link, if they're a good price I'll take 'em.  After all, they are broken Smiley Wink.

 

They flash amber every time you lose power, is that why you need to reset them? That would be a bit odd but I guess there could be something wrong with all of them.

If it's 'cause you can't find them with the app, you've probably got a dual band router - try connecting your phone to the 2.4GHz band SSID, the app should find them without needing a reset.

Mike
Reliable and secure (Belkin cloud-free) home automation and remote access:
AutomationManager/HomeBridge/WemoLEDs/WemoHome/MoreInfo
Posts: 2
Registered: ‎12-10-2016

Re: Wemo won't Connect to Wifi after power outtage

After every power outage, they flash amber, until I factory reset them. Can't find them in the app. Rebooting the router and switch doesnt fix it.

SUPER ANNOYING

Maybe they can fix with firmware update?

Posts: 5
Registered: ‎07-27-2015

Re: Wemo won't Connect to Wifi after power outtage

Ok ....

Here is what I did to finally solve my problem.

I have a TP-Link Archer C7 router. I logged into my router.
I went to DHCP. Under DHCP I went to the DHCP Clients List tab.

I located all my wemo devices. I did this by logging into my wemo app and going to Settings. Then to Settings and About.Then Hardware Info. Each device is listed including Mac address and IP address.

Go back into your router and reserve the IP address for each device with the appropriate MAC address.

For some reason the MAC addresses are off by one digit on each one ... but it did not matter. Use the mac address your router shows.

Once I did this ...no more problems. No matter how many times I restart the router.
I left one of my Wemos unplugged for a week and it found it right away.


Cheers
Bill

Posts: 1,064
Registered: ‎12-08-2014

Re: Wemo won't Connect to Wifi after power outtage

Not saying it should have to be this way but with all the Wemo's I have I always setup reservation and it seems to help discovery in a big way.
Posts: 1
Registered: ‎06-11-2017

Re: Wemo won't Connect to Wifi after power outtage

It seems to be like this so just follow these steps may be it will be solved your issue.

 

  • Please Unplug Your Belkin Router And Modem From Power Outlet .
  • Disconnect the Internet Cable Between Belkin router And Modem (Internet Services Provider ) .
  • Restart Your Computer And Wait For 1 minutes
  • Plug Everything Back And Turn The Router And Modem On .

For mor details kindly visit  Router Won't connect after power outtage

Posts: 3
Registered: ‎06-25-2017

Re: Wemo won't Connect to Wifi after power outtage

This process actually works. Of course, you have to know your way around your router, which MOST people don'tSmiley Sad And you also have to follow the excellent instructions the author, Bill, provided on how to find the MAC addressess for your WEMO devices...


@Valk wrote:

Ok ....

Here is what I did to finally solve my problem.

I have a TP-Link Archer C7 router. I logged into my router.
I went to DHCP. Under DHCP I went to the DHCP Clients List tab.

I located all my wemo devices. I did this by logging into my wemo app and going to Settings. Then to Settings and About.Then Hardware Info. Each device is listed including Mac address and IP address.

Go back into your router and reserve the IP address for each device with the appropriate MAC address.

For some reason the MAC addresses are off by one digit on each one ... but it did not matter. Use the mac address your router shows.

Once I did this ...no more problems. No matter how many times I restart the router.
I left one of my Wemos unplugged for a week and it found it right away.


Cheers
Bill

 

Posts: 3
Registered: ‎11-22-2017

Re: Wemo won't Connect to Wifi after power outtage

[ Edited ]

@MikeP wrote:

This might be the wemo bug where it can't reconnect to your wifi if your router moves to another channel, which can happen when your router is power cycled.  If it's set to select for the best channel (usually "automatic" or "scan"), try setting it to a fixed chanel, typically 1, 6 or 11.


Had exactly this issue.

 

After a power outage, the Wemo Maker could not reconnect, and even trying to set it up manually didn't work (it couldn't even see the network).

 

After manually forcing the channel to 1, the Wemo Maker finally managed to detect the network and connect to it.

 

I'm amazed the actual channel matters to Wemo but at least this gave me a way to fix it.

Thanks!

Posts: 3
Registered: ‎03-02-2019

Re: Wemo won't Connect to Wifi after power outtage

Old thread but I have this problem with recently purchased WEMO switches. I’m connecting to a dedicated 2.4ghz network and have reserved addresses. A power blip or unplugging makes them permanently lose network connection. Flashing orange. I have no such problem with any other IOT devices C’mon Belkin, why are we having to troubleshoot and deal with this kind of issue at this stage