WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Reply
Moderator
Posts: 313
Registered: ‎08-22-2017

Re: Wemos don't reconnect after rebooting the router

 @suprax

 

We'd like our Escalation Engineers look into this case. Please shoot us an email at WemoCares@belkin.com along with your contact details, community username, and the link to this community thread for reference and we can have them assist you further in this matter.

Carl_S 21985
WEMO Technical Support
Posts: 15
Registered: ‎01-02-2018

Re: Wemos don't reconnect after rebooting the router

Thank you for your offer.

I returned all my Belkin Wemo devices. Two weeks ago, I replaced them with a Leviton dimmer and TP-LINK smart plugs and bulbs.

Since then, everything has been working as expected, without trying to figure out that elusive router configuration hoping to smooth out the kinks. Firmware updates, the app doesn't lock up or crash, and everything reconnects automatically.

I just hope that whoever runs your support team will finally acknowledge that Wemo's software and firmware are flawed and start offering refunds. No one should have to change standard router settings to accommodate a product that is obviously malfunctioning.
Posts: 2
Registered: ‎10-19-2018

Re: Wemos don't reconnect after rebooting the router

Has this been solved?

 

One of the main uses of Wemo's is at remote locations. I have two switches at a remote location that I will not be able to return to for two months. The router reboots weekly. One switch comes back on line and the other one did so only after the first week. Now it is inaccessaible. 

 

We need a remote fix for this problem or Belkin needs to push a firmware upgrade.

 

Is anyone working on this significant shortcoming? If I have to be there all the time to cycle a Wemo, I can flip the switches myself.

 

Moderator
Posts: 313
Registered: ‎08-22-2017

Re: Wemos don't reconnect after rebooting the router

@FlyBoyMcCall 

 

We highly recommend to send us an email at WemoCares@belkin.com provided with the necessary info mentioned above so we can have the team look into your case further. They're the best people that could help us on this matter. 

Carl_S 21985
WEMO Technical Support
Posts: 1
Registered: ‎02-20-2019

Re: Wemos don't reconnect after rebooting the router

Hi Carl,

I just submitted a case # 10798263 regarding this issue. I have 3 x WeMo lightswitches that never reconnect after a router reboot. I have to walk around the house and hit the reboot button on each one for them to reconnect. It's very frustrating and like others have stated, other makes of smart devices reconnect without issue. Please chack out my case and reach out to me or add this forum thread if you can. I dont want to have to swap out 3 x lightswitches, I'd rather work with someone in tech support to get an updated firmware that resolves this issue. It's almost as if the lightswitch doesn't attempt to obtain a DHCP IP address in a timely fashion. Either that or there's something awry with the WiFi hadshake.

Posts: 5
Registered: ‎09-22-2018

Re: Wemos don't reconnect after rebooting the router

I had this issue and worked with Belkin’s Level 2 analysts on this. They couldn’t reproduce the issue in their lab and basically told me it’s my router. I then Purchased 6 Leviton smart switches that ALL worked fine and can recover from a router reboot. It’s not the router. For those experiencing this issue I would cut your loses and go with another manufacturer for any future smart switch/plug needs.
Posts: 1
Registered: ‎04-11-2019

Re: Wemos don't reconnect after rebooting the router

This issue just started for me after I set up a new Netgear XR500 router.  I have two of the original style WeMo plugs and a light switch.  Firmware on everything is up to date.  None of the WeMo devices reconnect when I reboot my router.  I previously had an ASUS router and did not have this issue.  Both the new and old routers are dual band.  I've also found that I have to rename them to reconnect them to my network.  I've set up the Guest network to not expire and only broadcast the 2.4GHz frequency.  If it wasn't for the fact that the switch is hard wired to the electrical of my house I would have thrown these in the trash and moved on to another manufacturer.  No other device in my house it having this issue.  All the other devices connected to the new router without issue when I set it up because I kept the same settings.  This is ridiculous.

Highlighted
Posts: 1,065
Registered: ‎12-08-2014

Re: Wemos don't reconnect after rebooting the router

2.4Ghz with N only and 20Mhz channel width on my Asus routers has ran great for years.