WEMO Hardware

Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Posts: 2
Registered: ‎01-12-2019

Wemo Switch Behaviour

Hello,

 

I've had two Belkin Wemo UK plugs for a little while now, and have had minor WiFi issues in the past but have found them relatively reliable.  Over christmas I used them both indoors to power tree lights, and now christmas is out of the way I decided to move one outdoors to power some garden lights.

 

The fibre internet connection comes into my house near the front, so I use powerline devices to get an ethernet port in the garage, then have a Netgear router acting as an AP to give me a further WiFi signal (and alternative SSID) out back.

 

Over christmas the Wemo devices indoors were connected to my main router and worked fine. Now that the Wemo device is in the garage, it's connected to the additional AP.  The AP itself works fine, it's setup with the same WPA2 encryption (and password) and I get a low ping / reasonable bandwidth using Speedtest.net for devices connected to it.

 

My Wemo device connects to this AP, albeit the blue light stays on for a few seconds then goes off.  The app on my phone shows the device and appears to have connectivity for a few seconds but then it shows as 'Not Deteced'.  The Wemo device is still able to power devices plugged into it, with the manual swtch on the front working fine - but for some reason it appears to lose all connectivity.  Every now and then the devices will appear as online on my app, but won't react then disappear again.

 

I'm trying to work out exactly why this might be, I've tried my second Wemo device and it behaves identically.  The primary variables here are the AP that the device connects to and the power supply that the Wemo device is plugged in to.  Any obvious things to try.  I would like to try the devices plugged into the house connecting to the garage AP and the devices plugged in outside connecting to the house WiFi but the Wemo doesn't seem to be able to detect the signal due to walls / distance.

 

Thanks

Rob

Posts: 2
Registered: ‎01-12-2019

Re: Wemo Switch Behaviour

So I've since been back into the house and connected to the house WiFi / main router.  Strangely the devices have appeared again, although not immediately, and I'm able to control them.  I guess the problem must lie within the garage AP, although I've connected my laptop to the same AP and I'm able to ping the Wemo devices.  It's strange, but the AP is somehow preventing the Wemo app communicating with the Wemo devices.

 

I guess it's time to debug the AP.

 

Rob

WEMO Maker Inventor
Posts: 1,773
Registered: ‎06-14-2014

Re: Wemo Switch Behaviour

The Wemo app doesn't work properly through APs, there's probably nothing wrong with your AP.  If you enable remote access, then turning off your phone's wifi it may make the wemos visible to the belkin app.  If so and you can give your router's 5GHz SSID a different name and use your phone there the app will always access the wemo's remotely through the belkin cloud and should be available more often.

 

Using an after market app might help, some work around the AP problem.

Mike
Reliable and secure (Belkin cloud-free) home automation and remote access:
AutomationManager/HomeBridge/WemoLEDs/WemoHome/MoreInfo